00 426 engine noise...please help!!!


22 replies to this topic
  • grayracer513

Posted March 29, 2006 - 05:43 PM

#21

...some superficial, no good, momma's boy who was born with a .... mouth

Edited for compliance with reality. The simple reason he's never worked for anything is because he's probably too young to drive, never mind get a real job. I wonder if he got his homework done before he got online tonight?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • canon del cobre raider

Posted April 03, 2006 - 11:40 AM

#22

Thanks to you guys! now I am little concern about the noise on my 2002 426, runs great, I changed the oil and I found some metal particles on the oil filter, I want to be sure that the balancer gear nut and the clutch basket nut are not loose, My question is how hard is to get to the balancer gear nut? Do I have to go through the water pump. I have worked on the clutch but never further than that/ please some help..Any special tools needed.

  • yogist

Posted April 03, 2006 - 04:58 PM

#23

I have an 01 426..I get noise on the left side..But I think its the chain..Kind of a clattering..I think its hitting the frame..Its a non o ring chain and rattles arounds a bit..
New sprockets and chain are in order...





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.