Yz Carb? Problem

No replies to this topic

Posted February 24, 2006 - 03:06 PM


My 02 426 Has Been Stood A Few Weeks While I Make Some Supermoto Wheels Fit. It No Longer Starts As Before, Takes Quite A Few Kicks On Choke & When It Fires Up It Runs Fine On Fast Idle But When You Open The Throttle It Tries To Die As If Its Too Weak. If You Build The Revs Slowly It Does Rev But Gives Flames & Bangs From The Exhaust. Does The Carb Need & Strip & Clean Or Could It Be The Throttle Position Sensor? Any Ideas Welcome, You Guys Must Know The Answer!

Related Content


Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.