Amsoil & Rekluse


4 replies to this topic
  • clark4131

Posted February 22, 2006 - 06:13 PM

#1

Since I run Amsoil in everything I own and plan on putting in a Rekluse in the next week or so, I emailed Rekluse regarding running Amsoil with the Z-Start since it contains no friction modifiers. Here's what they wrote:
[COLOR=Navy]

"Our recommendation is the Rotella T which is non-synthetic. The thing that affects our clutch the most is oil with moly in it. You can try a synthetic without moly. I ran Amsoil in my 2 stroke and had no problems. The 4 strokes tend to run quite a bit hotter and that is when you will notice a difference in your engagement."

[/COLOR]
I'm gonna give it a whirl and see what happens. If anybody has any direct experience with a zero-modifier synthetic and the Rekluse, please chime in...SC

  • byggd

Posted November 18, 2010 - 06:49 AM

#2

Since I run Amsoil in everything I own and plan on putting in a Rekluse in the next week or so, I emailed Rekluse regarding running Amsoil with the Z-Start since it contains no friction modifiers. Here's what they wrote:
[COLOR=Navy]

"Our recommendation is the Rotella T which is non-synthetic. The thing that affects our clutch the most is oil with moly in it. You can try a synthetic without moly. I ran Amsoil in my 2 stroke and had no problems. The 4 strokes tend to run quite a bit hotter and that is when you will notice a difference in your engagement."

[/COLOR]
I'm gonna give it a whirl and see what happens. If anybody has any direct experience with a zero-modifier synthetic and the Rekluse, please chime in...SC

Clark. I realize this thread is going on 5 years old but how did the AMSOIL work out with the Rekluse? Has anyone else run this combo?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • sierra77

Posted March 07, 2011 - 04:07 PM

#3

Been running Amsoil 10w40 MCF w/ the original z-start for 4-5 years & GYTR clutch plates. NO problems yet, works awesome!! I have a 04 YZ-450.....

  • Raider925

Posted March 07, 2011 - 04:29 PM

#4

Im running Amsoil 10w40 MCF with a Z-start Pro with no problems on a 07 WR450F

  • byggd

Posted March 08, 2011 - 02:29 PM

#5

I had sent Clark a PM some time back and he confirmed no problems as well. I started running Amsoil 10w40 MCF too and it might be my imagination but the think the Rekluse works even better that before!




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.