1 reply to this topic
  • Birdy426

Posted February 19, 2006 - 03:52 PM


Well, the WR 426 ran for the first time since the New Year today. Got about 25 miles on the new motor, gwtting the jetting squared away, and man, does it run strong!

Here's the recap on engine mods-
New crank, crank bearings, balance shaft bearings, primary drive gear, and balancer drive gear (the failure that caused the rebuild)
New oil pump
Hot Cams intake and exhaust cams
New stock valves, springs, retainers, seals and keepers
Porting and valve job by Eric Gorr
13.5:1 Wiseco forged piston (holy shit is it loud!)
JD jet kit (blue needle, 4th position, 170 main, and 45 pilot jet)
Tusk Clutch Kit w/HD springs

The rest of the mods are all the free mods, Twin Air filter, stock YZ pipe with Pro Moto Billet end cap, power now, and quickshot.

The power builds a whole lot quicker than stock, but there really isn't a big hit anywhere in the powerband. Just smooth and lots more of it!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 642MX

Posted February 19, 2006 - 03:58 PM


Awesome, glad you got it back together.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.