426 Running Lean

4 replies to this topic
  • bhollis426

Posted February 10, 2006 - 07:23 AM


Guys, I thought you might want to know that I cured my Lean problem on my 426. I bought a cylmer manual and checked the carb. The accelerator pump and spring were in backwards(not my fault) causing it to lean out. That explains why my jetts were so high (52 and 178). Anyway, just a bit of :thumbsup: information for you guys.

  • RD73

Posted February 10, 2006 - 07:33 AM


Nice work! :thumbsup:

Where are you in SC and where do you ride?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • bhollis426

Posted February 10, 2006 - 07:36 AM


I live in Myrtle Beach now, I moved from lake wateree. I used to ride up there, brown mountain, sumter, swansea, pelion, and anywhere else tight. How about you?

  • RD73

Posted February 10, 2006 - 08:56 AM


I've only ridden on some private land here in SC. Went to visit family last weekend in WV and took the bike. Good riding!

I'm looking for some good places to ride in SC though.

I live in Barnwell, not far from Aiken.

  • bhollis426

Posted February 10, 2006 - 09:13 AM


You should come and ride in the Pelion Enduro on March 5th.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.