06 YZ450F coolant leak

2 replies to this topic
  • kpflyingv

Posted January 29, 2006 - 08:56 AM


Brand new with two hours break in time. I just completed servicing the bike and fired it off to warm up when I noticed a small amount of antifreeze leaking from a small hole under the water pump cover. Dealer said it could be a bleed off but would call the tech line. Any ideas on this, as it still has two weeks warrenty?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • clark4131

Posted January 29, 2006 - 09:47 AM


Sounds like your bike came with a bad water pump shaft or seal. It's not a big deal, but if you're still under warranty make them fix it. I'm surprised your dealer didn't know what it was. If the "I don't know" came from the service department, I'd be extremely suspect of their abilities...SC

  • kpflyingv

Posted January 29, 2006 - 10:36 AM


Thanks, he didn't have a chance to really look it over closely, but assured me he would have his service dept take care of it. I am surmissing the coolant must leak behind the seal to drip from the hole. I guess that would be an indicator of a bad seal or shaft. Thanks again and I'll post what Yamaha finds when they look at it closely.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.