wr/yz stator swap.....help!!!


28 replies to this topic
  • slopoke

Posted January 25, 2006 - 12:02 AM

#1

is the wr stator that electrex sells the same as a stock wr stator?? electrex sells the kit stator and flywheel for 315....you can buy an oem flywheel and stator from a wr from mrcycle.com (who i get replacement parts from for numerous street bikes) for 250....

  • Matty05

Posted January 25, 2006 - 06:27 AM

#2

what model bike you got?

  • grayracer513

Posted January 25, 2006 - 07:53 AM

#3

The WR stuff prior to '03 can be used on YZF's of the same year. The WR450 and the YZ450 will not interchange at all in any way.

  • slopoke

Posted January 25, 2006 - 10:44 AM

#4

oh ya..it's an o2...sorry about that..i was just trying to make sure that it was a direct replacement deal and there wasn't any modifying that had been done to the electrex before i went off and just bought the stock stuff.....is the pink wire grounded on a stock bike where i had heard something like it was on the electrex model//???? or is there a wiring diagram somewhere for the stock wr yz deal?

  • slopoke

Posted January 25, 2006 - 10:13 PM

#5

anyone?? wiring diagram wr yz swap?

  • essex426

Posted January 28, 2006 - 11:47 AM

#6

anyone?? wiring diagram wr yz swap?

Shame. I was waiting for a good answer to this as well,before i fit my wr stator & flywheel.

  • PumpkinHumper

Posted January 28, 2006 - 06:08 PM

#7

I have a Wr 426 stator and flywheel on my yz400. I got it from electrex with the proper mods already done to the stator to make it compatable with the YZ's cdi. All I had to do is bolt it on and plug it in. All you have that is different is a yellow wire hanging off the harness. Thats your power lead. Wire that to your lite and run a ground. "T" in a voltage regulator on that power lead and run the regulator to ground and you are in business. Its just that easy.

  • essex426

Posted January 29, 2006 - 09:39 AM

#8

oh ya..it's an o2...sorry about that..i was just trying to make sure that it was a direct replacement deal and there wasn't any modifying that had been done to the electrex before i went off and just bought the stock stuff.....is the pink wire grounded on a stock bike where i had heard something like it was on the electrex model//???? or is there a wiring diagram somewhere for the stock wr yz deal?

Sorry to post jump.But just fitted 02 wr genuine yamaha flywheel and stator to my yzf 426 and not getting a spark.It has same block connector for wiring just 1 extra yellow wire,for lighting i assume.Anyway i am still using yzf ignition,just wondered if there is anything i missed, or maybe i just got a duff stator.Any ideas,cheers.

  • PumpkinHumper

Posted January 29, 2006 - 04:15 PM

#9

Essex you need to modify your stator to make it work on the yz. Check this PDF file out. It should help

http://www.electrosp...tator.4.yzs.pdf

  • essex426

Posted January 30, 2006 - 10:00 AM

#10

Essex you need to modify your stator to make it work on the yz. Check this PDF file out. It should help

http://www.electrosp...tator.4.yzs.pdf

Nice one,i spent hours yesterday searching posts with no luck, will get right on it.Cheers again.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • teamtoxic

Posted January 30, 2006 - 10:29 AM

#11

While we're on the topic...how does the output from the WR stator compare to an Electrex 45 watt coil? Just curious.

I'm running a 45 Watt coil on my 450 and am unhappy with the output. I'm currently running the output to a battery that I remove and recharge when I get back from a ride, but I'm lucky to have a few hours before my lights start dimming at idle (not so safe for the street). I'm thinking I may invest in an E-Line unit when this semester is over. Any thoughts?

  • essex426

Posted January 31, 2006 - 01:41 PM

#12

Hi, just covering my bases.sent an e-mail to electrosport,but in case i dont get a reply.On their page about the WR to YZ mod it does'nt say where to plug the pink wire after you have modded it and put a bullet connector on it.Any ideas.Yes i am dim. :thumbsup:

  • 93gt

Posted January 31, 2006 - 05:30 PM

#13

I am using the WR stator and it really puts out! I did the mod a few months ago and got all the answers I needed from electrosport. They were a HUGE help and answered all my questions correctly. I think there is a ground issue thats holding you up here. What are you using for a harness? I bought the Moose Trailsport one for around $80 from Dennis Kirk. It had the provisions for brake switches as well (nice for keeping your buds form slamming into you on the trail)

  • essex426

Posted February 01, 2006 - 08:50 AM

#14

I am using the WR stator and it really puts out! I did the mod a few months ago and got all the answers I needed from electrosport. They were a HUGE help and answered all my questions correctly. I think there is a ground issue thats holding you up here. What are you using for a harness? I bought the Moose Trailsport one for around $80 from Dennis Kirk. It had the provisions for brake switches as well (nice for keeping your buds form slamming into you on the trail)

Not even got to a harness yet, need to get a spark from the engine first.Have done the stator mod.I just need to know where i should plug the pink wire.(The one you extend by 3" and fit with a bullet connector.)Like electrosports diagram.Not got an answer from them yet,(i emailed them.)After that i sould be able to figure the light out ok.

  • PumpkinHumper

Posted February 01, 2006 - 12:48 PM

#15

Not even got to a harness yet, need to get a spark from the engine first.Have done the stator mod.I just need to know where i should plug the pink wire.(The one you extend by 3" and fit with a bullet connector.)Like electrosports diagram.Not got an answer from them yet,(i emailed them.)After that i sould be able to figure the light out ok.


I wish I could help you our more there. I bought mine from Electrex already modified to work on my YZ. All I did was bolt it up, plug in the main harness and plug in the yellow wiree to the headlight.

As for the 450 fella's question the WR426 stator puts out 130 watts. Way more than the 45 watt jobby. I had the 45 watt one and didn't like it. The WR 426 one is the way to go. BUT it wont work on your 450. The 450 and 426 have diff cranks. The stators arn't interchangable. And I believe that the crank on the WR450 and yz 450 are diff as well so you are doubly screwed. I think your only option is to use a e-line stator. Those put out like 200 watts. But they are like $400.

I was looking at that Moose Harness. That does look pretty nice for the $80.

  • essex426

Posted February 01, 2006 - 01:42 PM

#16

I wish I could help you our more there. I bought mine from Electrex already modified to work on my YZ. All I did was bolt it up, plug in the main harness and plug in the yellow wiree to the headlight.

As for the 450 fella's question the WR426 stator puts out 130 watts. Way more than the 45 watt jobby. I had the 45 watt one and didn't like it. The WR 426 one is the way to go. BUT it wont work on your 450. The 450 and 426 have diff cranks. The stators arn't interchangable. And I believe that the crank on the WR450 and yz 450 are diff as well so you are doubly screwed. I think your only option is to use a e-line stator. Those put out like 200 watts. But they are like $400.

I was looking at that Moose Harness. That does look pretty nice for the $80.

No problem,i got it sorted, just ground the black wire,and now i've got a spark back.The other wires-yellow/pink are used for lights/ charging i think.Thanks for help anyway.

  • slopoke

Posted February 01, 2006 - 11:24 PM

#17

they seem nice, but dang, they're expensive...and isn't the pink wire supposed to be grounded??

  • essex426

Posted February 02, 2006 - 07:16 AM

#18

they seem nice, but dang, they're expensive...and isn't the pink wire supposed to be grounded??

I suppose it is,because you cut the pink wire.The end from the stator goes to the lights same as yellow wire,and the block connector end gets extended with a black wire and grounded by the coil.

  • slopoke

Posted February 02, 2006 - 05:19 PM

#19

so did you get your stock wr stuff to work on your yz yet?? also, do you know if a wr400 stator would work?

  • essex426

Posted February 04, 2006 - 03:26 AM

#20

so did you get your stock wr stuff to work on your yz yet?? also, do you know if a wr400 stator would work?

Yes i did.Had to mod the stator for it to run though.I spent more time looking for infomation than soldering though.Im not sure about wr400,apparently 426 will work on 400.Check out yzman 400's posts he has some usefull info.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.