2002 426 front brake disk loose


2 replies to this topic
  • kurtsyz426

Posted January 06, 2006 - 06:04 AM

#1

Can anyone help me with some advice please ??

I was checking my front bearings one the weekend just gone and found that the washer thingo's which fasten the front brake disk to the wheel are worn and hence loose (when i apply the front brake there is give in them). The design of this does not seem too secure and hence I am seeking advice to fellow 426 ers to see if there is a mod for this, or if not, what i need to do to fix this up (other than replace the front disk ??)..

Thanks heaps..

Kurt

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • sirthumpalot

Posted January 06, 2006 - 06:29 AM

#2

It's a "floating" front disk and some movement is normal. That's why the disk is attached with those snap-looking things instead of bolted. It shouldn't be rattling around like it's going to fall off, but some movement is definitely normal.

  • essex426

Posted January 06, 2006 - 10:16 AM

#3

Its normal, they all do it.Floating disc.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.