finally adjusted my valves- yz426


No replies to this topic
  • solaidrider667

Posted December 31, 2005 - 06:54 PM

#1

A while back my bike was very hard starting and just wanted to thank all who sent me in the right direction :applause: -thank you
She runs great again :cry: -------still seams more(than normal) noisey inside right side covers but I think its just its nature. I did pull clutch cover and clutch assembly out and nothing unusual,no metal scoring etc. I am also on my oe clutch.
Again, thanks to all and to all a wide open New Year!!! :bonk: :cry:

My sponsers rock-
Solaid Clothing-JBP FILMS-661-Sam's Cycle-Prics Tattoo-Kieth Grable





Related Content

Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo
Supercross

Wilson the Blue Privateer by jetfuel


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  50 replies
Forums
Photo

The "going back to the other darkside" adventure... by Monk


Dirt Bike   Make / Model Specific   KTM   250/350/450/505 SX-F & XC-F (4-Strokes)
  • Hot  113 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.