Clutch problem



1 reply to this topic
  • MXH

Posted September 02, 2001 - 11:16 PM

#1

During a race a couple of weeks I was a bit overenthusiastic with the clutch and it started to slip. I stripped it down and all seemed to be OK so I put it back together, with an oil and filter change to be on the safe side. Tested it and again it was fine - no problems.

However, racing this weekend, a couple of hours in to the event the clutch started to rattle when engaging. It was OK when fully engaged and OK when fully disengaged, but when feeding it/slipping it, it would rattle. Considering it just started happening (ie not there one minute, then it was - I don't think it's just wear and tear). I'm going to strip it down tonight to have a look, but has anyone got any pointers as to what the problem might be?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Buck

Posted September 07, 2001 - 04:40 PM

#2

Three things come to mind.
1. Warped metal plates or pressure plate.
2. Broken clutch springs.
3. Notched clutch basket where the friction plates make contact.

Hope this helps

Buck




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.