Aftermarket Gas Cap Vent Cap Problem


3 replies to this topic
  • tony1970

Posted December 11, 2005 - 02:39 PM

#1

I installed one of those aftermarket gas cap vent caps, the ones were it is about a 2 inch hose with a cap on top. From the beginning this thing has leaked when the tank is full. I safety wired it twice at the cap because I thought it would leak there, but the problem is the gas is getting slopped around in the tank, gets into the caps baffle and gets forced out of the vent cap. Once I use about a 1/4 tank of gas it stops leaking. I have checked the vent cap it is not plugged and I am not overfilling the tank. Has anyone had this problem , and how did you fix it? The caps baffle seems to be a bad design that it does not allow the gas back into the tank fast enough. I'm thinking a longer hose but even when the stock vent tube was in you could see a small amount of gas coming out of that thing too. Thanks for the help.

  • RCannon

Posted December 11, 2005 - 02:49 PM

#2

Mine sucked as well. I ended up going back to the original model. Same story and problems that you have had.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • TARFELE

Posted December 11, 2005 - 03:31 PM

#3

I lost two of them while riding. I wont buy another!

  • Matty05

Posted December 11, 2005 - 03:36 PM

#4

Mine works just fine. I have one on the WR250 also and that works perfect too.
http://www.ballards....ils&content=401

My stock one used to leak a bit, but this vent rocks!




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.