New 04 WR450 ?'s

22 replies to this topic
  • AUS_WR450

Posted March 18, 2006 - 05:41 PM


Why? Could you explain.

There is a rubber plug on the front, top RHS of the engine, where a decompressor lever used to be on earlier models. It has been known for this rubber bung to 'blow out' and spew oil everywhere. You can replace it with aftermarket plugs, or you can take the cheap arse option like I did. :thumbsup: I just used a small piece of aluminium angle and used the existing bolt to hold it in place. See the pic in the link below and it should make it a bit clearer for you.

cheap arse bung fix


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • TWR

Posted March 18, 2006 - 08:26 PM


Ah, now I am informed. I like your method best. Real inginuity.

  • WheelsUp

Posted March 18, 2006 - 08:55 PM


Just spend the $20 on a nice machined plug from the TT store and you'll never have to worry about it. It duplicates the original factory part from the '01/'02 models but does not have the cable attachment or actuator. It fits like it belongs there.

Eventually, the stock plug WILL (not might, will) fall out. If you're lucky you'll notice it before all of the oil is blown out.
If you're not lucky, the oil blowing on the header will burn, or you'll seize your engine.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.