rear brake broke

1 reply to this topic
  • INJURY_69

Posted November 10, 2005 - 09:38 PM


Was doing some trail riding, nothing spills.

Then I notice the back brakes stopped working.

After closer look the bolt holding the unit to the frame broke off and the pedal was hanging on just by the spring.

I did a search and found no posts of anything similar.

Luckily I replaced the unit by taking the bolt off of my bro's '02YZ250F.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Fizz

Posted November 10, 2005 - 10:05 PM


perhaps the bolt was a bit loose, then its not hard to break one ..

every screw without "loctite" or lock nuts (?!) keeps unscrewing itself on my '02 YZ426F ..

Related Content


First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.