Tail light in/op.... question

1 reply to this topic
  • justicedone

Posted September 29, 2005 - 06:43 PM


My tail/brake lamp went out on Sundays ride apparently. I was gonna ride my bike to work in the morning so went to Autozone and grabbed some bulbs thinking it was just popped from age/ vibration etc.

Put new bulb, nothing..checked all the fuses, nothing was blown, no running lamp or break lights and no power to wires at socket.

I was losing daylight so I garaged her for the night, will trace the wiring further tomarrow or sat. But i was wondering if theres anything else I may be missing here.

Somebody may have encounted a problem that I am now facing. I am sure its not a big deal, but want to fix it and ride ASAP.

Thanks for the help, (or retarded spam) in advance



Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • GIANTac1

Posted September 30, 2005 - 02:35 PM


Whats up dude! Miss riding w/ you guys!
I lost my tail light up in nor cal. Found out the ground wire broke off and was Hidding in the sleeve......POS! Check it out, if you got a soldering gun you can fix it.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.