Stator/light troubles???


3 replies to this topic
  • 600ish

Posted September 24, 2005 - 07:59 PM

#1

I installed a 2x100w Stator in an '01 650R and the 100W BD headlight works great but our Cyclops helmet light worked very bright for a few minutes and then blew the bulb. What do I need to do to get this 55W Halogen bulb to work correctly. Thanks :lol: :banghead: :applause: :lol:

  • don87xr600

Posted September 24, 2005 - 09:26 PM

#2

Call Ricky Stator, they are extremely helpful.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Max Power

Posted September 25, 2005 - 07:00 AM

#3

What voltage does the meter say you are putting out?

  • 600ish

Posted September 25, 2005 - 01:56 PM

#4

I will call Ricky Stator Monday and the bike is a friends and we rode Sat. and all is great with the bike for Vegas to Reno Except for the helmet light and I haven't had a chance to pu a meter on it yet. I'll see Mon. night. Thanks again. I'll sure be glad once we can get the race on because the pre-race prep is keeping me running day and night. :banghead: :lol: :applause: :lol: :lol:





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.