98 wr400 odo eliminator


10 replies to this topic
  • Messiah

Posted September 11, 2005 - 06:40 AM

#1

been looking around for a 98 wr400 odo eliminator. flatlandracing and barumspro don't seem to have them.

anyway searched this forum and pple suggested that the yz counterpart fits nicely. however the p/n for the hubs are different :banghead:

anyone have any idea if it works for the 98?

  • simon@vic

Posted September 11, 2005 - 08:56 AM

#2

just remove the cable and cap the threaded part.........

  • bdmmotard

Posted September 11, 2005 - 09:33 AM

#3

just remove the cable and cap the threaded part.........


+1.

i'm running a trail tech, but i'm thinking about finding a mechanical speedo off a 17" tire street bike. i think they're cooler and more reliable.

  • Birdie426

Posted September 11, 2005 - 10:09 AM

#4

I had read that the YZ spacer won't work (Don't remember where). Plus, the WR doesn't have a seal outside the speedo side bearing like the YZs do. I expect that's the major difference...

Are the 98 WR hubs same as the 01 WR's? I just ordered one from Barnum's for my 01 WR. I'll let you know how it works.

  • Messiah

Posted September 11, 2005 - 04:31 PM

#5

I had read that the YZ spacer won't work (Don't remember where). Plus, the WR doesn't have a seal outside the speedo side bearing like the YZs do. I expect that's the major difference...

Are the 98 WR hubs same as the 01 WR's? I just ordered one from Barnum's for my 01 WR. I'll let you know how it works.


5BF-25111-00-00 vs 5BF-25111-01-00. not sure what the numbers mean.

do keep me updated on how well it works anyway. thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • katoom525sx

Posted September 16, 2005 - 12:05 AM

#6

+1.

i'm running a trail tech, but i'm thinking about finding a mechanical speedo off a 17" tire street bike. i think they're cooler and more reliable.




Copy that I think the trail tech is junk so I put a xt350 speedo on my wr250f

  • Birdie426

Posted September 17, 2005 - 11:06 AM

#7

Barnum's is backordered on the speedo drive eliminator for my 426, and don't know when they will be available...so I ordered the YZ spacer and seal today. Should be here by mid week. I'll post the results.

  • so_cal_sean

Posted September 19, 2005 - 08:31 PM

#8

what was wrong with the trail tech i was just looking in to buying one

  • Birdie426

Posted September 23, 2005 - 11:19 AM

#9

I got the YZ spacer today, and it works just fine. You do have to run the YZ bearing seal, though, as the WR doesn't have one on that side of the hub.

  • Messiah

Posted September 23, 2005 - 07:01 PM

#10

thanks!

  • SJMC_DON

Posted September 26, 2005 - 07:51 PM

#11

This is right :banghead: the YZ spacer will work, yes the hubs are different but only where the WR has the "cup" where the odo head goes on with the little tabs that actually spin the odo head. If your odo head has not grenaded (like mine) you can just unscrew the cable and buy a small rubber cap at any hardware store to cover it with, like mentioned above. Otherwise make sure you buy a YZ spacer and a YZ seal kit (2 seals versus 1) and you are good to go :applause:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.