Clutch Dragging

2 replies to this topic
  • jim-in-so-ore

Posted September 09, 2005 - 05:28 AM


A while back I installed a Magura "jack" clutch kit on my 03 WR 450f. Last evening I re-did the wires so I could start it in any gear with the clutch pulled in. My problem is there is no adjustment on a hydraulic clutch, and the clutch drags while trying to start the bike in gear. Maybe after the bike is warm it won't drag but cold it wants to move forward. Any suggestions, ideas, or downright wild ideas would be appreciated. Thanx in advance.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • MathProf

Posted September 09, 2005 - 05:40 AM


The clutch dragging can be worst with new heavy oil in a cold motor.

Ride it and see if it changes.

  • Indy_WR450

Posted September 09, 2005 - 07:45 AM


This is normal on our bikes. A cold clutch will drag. Just try putting a cold bike in gear and push it around. That is too much load for starting. Start a cold bike in neutral then you can start it when hot in gear with the clutch pulled in. :banghead:


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.