Clarke 2.8 Gallon Tank on 05 WR450


4 replies to this topic
  • motodude42

Posted July 08, 2005 - 04:43 PM

#1

I just installed the Clarke 2.8 on my bike this past weekend. Had a few
minor issues. When I pulled the petcock (funny word) :) off it has the
reserve which has two pipes going into the tank. My new Clarke tank only had
one hole. I had to drill another one to install the petcock. :D I installed
the petcock on the new tank using the original oring and I could not get it to seal. I removed the oring and used the supplied gasket and so far it is holding tight with no leaks after one ride. The other issue I had....I had to shim down the rubber that goes across the frame under the tank to get the tank mounting bolts to line up. Anyone else have these issue with this tank? It is good to go now, but....I did not feel I should have had to do all of this to get this installed. :)

  • lairpost

Posted July 08, 2005 - 04:50 PM

#2

I'm curious why you got the Clarke...isn't the stock tank 2.6 gal?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • HarveyMushman

Posted July 09, 2005 - 08:07 AM

#3

I didn't have any of those issues with my clarke. It was a perfect bolt on.

  • motodude42

Posted July 10, 2005 - 02:20 PM

#4

That makes me wonder if they sent me a YZ model???? :) The stock tank on a 2005 is 2.1 gallons.

  • motodude42

Posted July 10, 2005 - 02:22 PM

#5

Did you use the oring or the supplied gasket?




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.