engine breaking much less, all of a sudden?


1 reply to this topic
  • minion

Posted July 04, 2005 - 10:06 PM

#1

I have an 05 WR450 that just hit 110 miles. I took it for a 14 mile drive (decent speeds - mostly 40mph - on the street - as high as 60mph for 2 or 3 of those miles)...

Either way, I get to my destination.. Several hours later, I ride home, and notice that the bike's engine braking isn't there nearly as much as it used to be... It used to be bad enough to want to throw you over the bars if you weren't paying attention (especially in the woods, where your balance might be all over the place)... Now it slows down much more like my street bike - some braking, but not a whole lot.

My question is, then, did something break? I don't hear anything weird, it runs fine, and accelerates fine, doesn't burn any oil (that I can see, anyway). I checked the oil, and it still looks like new (I changed it about 30 miles ago). It just seems like it happened too suddenly for it to be normal break-in.

Thanks guys,
M.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Matty05

Posted July 04, 2005 - 10:14 PM

#2

It sounds normal to me.

Mine used to do the same thing. Your engine will only get better and make heaps more power as it starts to free up as 110 miles is nothing :)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.