WR400 kicking out loads of oil

5 replies to this topic
  • jasonsmith1000

Posted June 24, 2005 - 02:42 AM


I have a 99 WR400 and just had the engine rebuilt but its kicking out loads of oil out the breather(so much i have to refill it after even short rides) it is currenty with the bloke that rebuilt it and he can't work out what's wrong with it

Any ideas please would be greatfull


  • Flash319

Posted June 24, 2005 - 02:53 AM


Sounds like you have a tonne of blow-by. What got rebuilt? Piston rings, head..... I would say either your rings didn't seat or your valve guides are gone. The compression on top of piston is getting to the valvetrain or past the piston. Something went wrong with your rebuild.

Do a leak down test. This will tell you if everything is sealed tight in the cylinder.

  • TwoBobRob

Posted June 24, 2005 - 02:55 AM


Hi Jason.

Stupid question I know, but did it start with the correct oil level, and is it being checked correctly now? If it was vastly overfilled to begin with, it would piss out everywhere for sure..... :)

Whereabouts in the UK are you?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • jasonsmith1000

Posted June 24, 2005 - 03:04 AM


I checked the oil as per the workshop manual and its still kick out the oil at half full

The rebuild had almost all the parts replaced in it can't remember what was exactly done but I know it’s had new pistons the head was skimmed and some bearing were replaced not to sure which one the final bill was £900

and i'm in bristol

  • TwoBobRob

Posted June 24, 2005 - 03:14 AM


Essex boy, me. Sounds like Flash might be right, somethings getting past... If you want to pick somebody's brains, a couple of my mates have had their engines rebuilt by Bob Farnham in the Brands Hatch area. Apparently he's very good and knows the Yammy lump inside out. Sorry, I don't have a number for him. Good luck :)

  • DesertChris

Posted June 24, 2005 - 12:36 PM


If I had to guess I would say the rings have not seated to the cylinder. The cylinder on the WR's is aluminum with a Nikasil plating. This stuff is extremely hard and I don't think a regular ball hone will break the glaze (smooth surface made in the cylinder by old rings). I believe a diamond hone is used for this stuff. If the cylinder is still smooth, the new rings wouldn't have a rough enough surface to seat and allow excessive blow-by into the crankcase. The blow-by exits the case from the top vent carrying oil with it, it should also cause oil to be burned in the combustion leaving excessive greasy soot in the exhaust pipe.

A cylinder leak-down test will confirm if this is the problem. This is the test where a measured air flow in injected through the spark plug hole and the cylinder and piston are checked for their ability to hold the air flow. The air escaping from the cylinder can then be heard, in this case from the crankcase vent. Air escaping through the carburetor or exhaust would be valve seating issues and bubbling coolant would be a head gasket, though these wouldn't be the cause of your oil problem.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.