brp kick start problem?

8 replies to this topic

Posted June 08, 2005 - 03:43 PM


my kick starter every once and a while when i am giving it a real hard kick to start feels like it will skip one tooth. my bike is still on warranty and when i called the shop they say they will have to tear into it to see if there is a problem. If this is a normal thing for these bikes i would rather they don't mess with it.if anyone else has experienced this please let me know

  • big t

Posted June 08, 2005 - 05:00 PM


Mine will act like it is grinding or binding up. Sounds like the same thing you are talking about. I have had my side cover off and looked at it. Nothing wrong. I have heard a couple of others say the samething. I would not worry about it unless it gets worse.

  • Tber

Posted June 08, 2005 - 05:38 PM


mine does the same thing, but only when trying to start w/o decompression.

  • Hd_hubub

Posted June 09, 2005 - 09:01 AM


Ditto on that. That skip you describe makes me a little nervous when I am far from home, but the next kick or two it fires up.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed

Posted June 09, 2005 - 11:11 AM


well it is starting to look like it's the nature of the beast!! sure am glad i didn't let them tear open my engine :) :) :D

  • skyriver

Posted June 09, 2005 - 11:39 AM


If you just kick it out of the blue you'll feel that. Find TDC (top dead center... you know the spot that will kick you off if you weight less than 200 pounds), bring it up 1 or 2 clicks and kick it hard. You'll never feel it again. The BRP has auto-decompression and I would have to think you're feeling that system trying to work. Not sure.

  • justicedone

Posted June 09, 2005 - 11:46 AM


You could always drop a few fat bills on one dem newfangled push button dohickies...

Like us L owners gotsissss

  • captb

Posted June 09, 2005 - 02:11 PM


The idle setting is important mine likes it on the rich side and if it sits for awhile I put the choke on and it starts first kick, then there's the old big bore 2 stroke trick allways park on a hill, put it in 2nd gear get rolling and let the clutch out.

  • stoo

Posted June 10, 2005 - 01:14 PM


Mine does it too - I've always assumed it was just down to me still not getting my head round the auto-decomp.

I'm getting the autodecomp removed when I change the cam, but it's never caused me a problem. :)

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.