05 wr 450 backfiring on deceleration?

11 replies to this topic
  • dmack

Posted June 01, 2005 - 12:39 PM


Hey guys, whats up with this thing backfiring on deceleration?
I have done all of the "free mods"
gray wire
throttle stop

Is this normal, or how can I fix it.


  • motojason

Posted June 01, 2005 - 12:53 PM


Remove the AIS. That will help to get rid of the lean condition in the exhaust that is causing the backfire. TT store has a good plug kit for sealing up the holes once the parts are removed.

  • dmack

Posted June 01, 2005 - 01:01 PM


thanks moto jason
what does the ais actually do?
and does it rob power ?

  • byggd

Posted June 01, 2005 - 01:45 PM


AIS Air Injection System aka smog pump. Yamaha added it for 05 450 to get it green stickered.

  • moach1

Posted June 01, 2005 - 06:30 PM


does not rob power. once i removed mine, no more popping. i think the ais removal kit is a must have!!

  • Fredneck75

Posted June 02, 2005 - 05:18 AM


Removing the AIS alone may not be enough. You will probably want to rejet to get it just right.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • clark4131

Posted June 02, 2005 - 06:32 AM


For an '05, backfiring on deceleration is usually caused by one or a combination of the following:

  • AIS
  • Lean needle position
  • Lean fuel screw adjustment
  • Lean pilot circuit
  • Loose connections in the exhaust system

Check and adjust each of these individually and you'll figure it out...SC

  • cgrlvr35

Posted June 02, 2005 - 09:05 AM


Is that just for the California bikes purchased in that state? I bought mine in Oregon. Do you have a photo odf the AIS procedure?

  • farkawi

Posted June 02, 2005 - 09:32 AM


I'm at 5280' and mine still popped after AIS removal till I rejetted. I'm running a 50 pilot which is a bit rich (waiting for a 48) I raised the needle by inserting a .020" washer under the needle clip. You have to pop the aluminum plug outa the float bowl side to get access to the fuel screw which I'm running at 2-2 1/2 turns out.

  • clutchinoregon

Posted June 07, 2005 - 08:33 PM


what about the yz 450? ( 05 ) mine too has a little popping on decel. dealer told me normal... but id sure like to get rid of it

  • Dan_Lorenze

Posted June 08, 2005 - 06:54 AM


I'm not so sure I'd blame it on the AIS.. I would say there's a 90% chance your Pilot jet is too lean... All these "Free mods" will do very little without proper jetting specs... Go to the Jetting Database and see what we're all runnin... :)

  • motojason

Posted June 08, 2005 - 11:26 AM


Dan is right about it not being all related to the AIS. I meant do the AIS removal and then re-jet. I've got a JD kit and am using the settings recommended in the Jetting Database. Now my bike runs great!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.