Z-Start question? AL?

3 replies to this topic
  • FOX426

Posted May 19, 2005 - 06:13 PM


Has worked flawlesly for almost a year. Gasket started to leak so I replaced it with the Rekluse clutch cover and a new stock gasket. Everything seems ok until I pull in the clutch lever (overide). It makes a grinding, dragging sound and the cover gets very hot. What have I messed up? :)

  • FOX426

Posted May 20, 2005 - 06:34 AM


Where's the Rekluse experts? :)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ncmountainman

Posted May 20, 2005 - 06:43 AM


not al but,the rekluse cover should have given enough clearance with the stock gasket? try one of the really thick reusable gaskets rekluse offers,its alot better gasket anyhow,check your install gap and look for anything askew?

  • FOX426

Posted May 20, 2005 - 12:03 PM


Thanks, will do. My guess .... not enough clearance, for some reason.

Related Content


Snake pit oct 30th by The Anvil

Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  106 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.