chain wear on sub-frame

5 replies to this topic
  • timcook

Posted April 15, 2005 - 09:54 PM


Anyone ever noticed if their chain has contacted the inner portion of the aluminum sub-frame above the chain? :naughty: :naughty:

  • clark4131

Posted April 15, 2005 - 10:01 PM


Yep. It's something of a design flaw. All the WR's have it. There isn't a whole lot you can do other than rig some sort of protection like an extra piece of aluminum, inner tube or similar fix...SC

  • RB2

Posted April 16, 2005 - 07:27 AM


Yeah. I got it too. Only 10 hours on the bike. Like Steve says not much you can do. If any has any ideas or pictures of fixes it would help a lot of us out

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 99wr400

Posted April 16, 2005 - 11:04 AM


weld a piece of 1/8 inch aluminum to the inner side of the subframe that gets rubbed by the chain, make the aluminum piece as long as the part of the sub-frame that can be touched by the chain.

  • mmi100sguy

Posted April 16, 2005 - 04:08 PM


is anyone using the tm designworks chain slider to fix this problem? i know i've seen the post about putting foam & silicon but i just figured this would look if not work better

  • INJURY_69

Posted April 16, 2005 - 05:16 PM


I use that TM chain slider...seems to fix the problem so far. It is a thick heavy duty unit that doesn't move or use any of the factory bolts/nut-washer-thingy. :naughty:


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.