Starter/Kill Switch SUCK!


9 replies to this topic
  • bandit99

Posted April 13, 2005 - 07:49 AM

#1

I have an 05 WR450 and the little red and gray buttons have popped out on the starter and kill switches. Crappy design. Has this happened to anyone else? I think I am going to replace with regular type kill switches. Any other suggestions?

  • DesertWR

Posted April 13, 2005 - 08:04 AM

#2

My friends did but only after he wrecked his bike.

  • Canuck

Posted April 13, 2005 - 08:18 AM

#3

I have an 05 WR450 and the little red and gray buttons have popped out on the starter and kill switches. Crappy design. Has this happened to anyone else? I think I am going to replace with regular type kill switches. Any other suggestions?


try changing the position of the switches to the under side of the bar...

  • viking50

Posted April 13, 2005 - 09:22 AM

#4

Happened to my brother's '03 450 about a year ago, doesn't seem to affect the performance of the switch. Red cap just falls off.

  • ddialogue

Posted April 13, 2005 - 12:23 PM

#5

Yes, they suck! Just replace them with standard switches when the originals break. :naughty:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • mousemeat

Posted April 13, 2005 - 12:31 PM

#6

anyone know where to get the plug end of the switch? This is for an '04.

  • ddialogue

Posted April 13, 2005 - 12:38 PM

#7

anyone know where to get the plug end of the switch? This is for an '04.


You could probably get it from Yamaha but what I did was cut the connector off (a few inches up from the connector) and solder and shrink wrapped the new wires to it. Fast, easy, and no new connector to buy. :naughty:

  • bandit99

Posted April 14, 2005 - 07:04 AM

#8

Good to see I am not crazy....a little maybe but thats another story.

  • Dan_Lorenze

Posted April 14, 2005 - 07:56 AM

#9

Yep.... They SUCK!!!! A month ago my starter button fell off and actually had to "Kick" start my bike... The Horror.... :naughty:

My shop was out of the 05 button so I put one on from a TTR125, same button different connector, I just changed the connector,pretty easy..

Dan

  • J_DOGG

Posted April 14, 2005 - 08:17 AM

#10

Not yet!

I have not crashed too hard yet though....




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.