GYT-Insert bolt poor quality 03 WR450

11 replies to this topic
  • amaxwell

Posted April 11, 2005 - 08:58 PM


Anyone else had continuous problems keeping your GYT Insert to stay in the stock 03 WR 450 muffler? The bolt has worked it's way out several times. I've since put a little spot weld on the end of the bolt inside the pipe and that helped for a hundred miles or so. Now the bolt has loosened itself up again and it's rattling pretty good-but the spot weld has held. I suppose the bolt itself is just falling apart.
Other than the obvious "get an aftermarket pipe" answer, please any help with keeping this insert in the pipe would be appreciated.


  • Desracer

Posted April 11, 2005 - 10:37 PM


The only thing that had work is a hose clamp around the end tip and bolt to hold it in place. The back pressure from this insert really wears on the bolt. PMB has a much better tip design and my bike runs better with it than the GYT one. The PMB tip has never came loose!


Posted April 12, 2005 - 04:30 AM


I've been using a socket (allen) head bolt that I drilled and safety wired. It has never come loose in over a year of riding.

  • Chevy_Cowboy

Posted April 12, 2005 - 05:08 AM


I've got a 04 with the GYT insert... never had problems with the bolt coming loose but I'm not very happy with the insert. It leaks around it and hurts the sound quality IMO, I'm wishing I would have bought one of the aftermarket ones that have the rubber seal around the edge.

  • jim-in-so-ore

Posted April 12, 2005 - 05:42 AM


I lost the bolt in mine and had the insert blow out while riding so I used a longer bolt and double nutted it. I never came loose again,but I noticed that it was probably choking it down so I removed that and retapped the hole to 1/4-20, plus drilled another hole on the other side and tapped it also and never had another problem. :naughty:

  • bluethundaaaa

Posted April 12, 2005 - 09:42 AM


I double nutted a standard bolt and it broke that on the first ride. So then I used a grade 8 bolt and double nutted that. I have not had a problem since although it does leak around the outside and it does rattle a bit so someday it will pop out again if it wears that bolt out.

On a side note don't pick up a newly blown out insert....those things are hotter then hell. I (being the idiot I am) did that once......that was stupid. I burnt through my gloves and blistered my fingers in less than a second. Ouch! I was cussing that GYTR insert that day. :naughty:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • BajaFool

Posted April 12, 2005 - 10:30 AM


I wallowed out the threads on my insert and lost the bolt also. I had a helicoil installed in the GYT-R insert. I drilled a hole in the head of the new bolt and used safety wire, as well as locktite. I have had no problems so far. Yes, and I picked up the GYT-R after it fell out of the exhaust also--- new gloves melted in a heartbeat. :naughty:

  • black_n_blue_thumper

Posted April 12, 2005 - 08:20 PM


Ya too loose of a fit. I used the double nut technique too. Then I just said the hell with it and got a GYTR pipe. Best move I ever made. However not near as cost effective. :naughty: I hear the PMB inserts are much better.

  • jdd123

Posted April 13, 2005 - 09:49 AM


I had a similar problem on a previous WR250. The bold was too short and would strip the threads on the insert. I got a longer bolt that stuck through all the insert threads. It fixed the problem and never fell out.

  • goldy33

Posted April 16, 2005 - 06:17 PM


Just Added The Gyt Insert To My 03 Wr450-must Have 70 Or So Miles On It So Far And No Problems

  • billygoat

Posted April 17, 2005 - 08:52 AM


My Quiet Products insert works great and has a great sound. At $42 bucks it's the best thing going. The bolt screws into a steel ring, so no nut to come loose. I check it from time to time, but it's always tight. Nice chrome finish too.

  • goldy33

Posted April 21, 2005 - 03:25 AM


well i put on aroung 120 miles with my gyt pipe insert now and i was about 40 miles into the woods when i heard a rattle coming from the back of my bike, so i stopped and sure enough the bolt for the insert wiggled its way loose, so i tightened it finished my ride, when i got home i took the bolt out and put some high temp lock-tite on it and hopefully i will have no more problems;)


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.