Sputtering in the low to mid rpm range???


1 reply to this topic
  • miah

Posted March 27, 2005 - 01:32 PM

#1

Well I finally got one. I just bought a 03 WR450, I made it street legal to go to and from work when its not the weekend, The problem that I am having is when I am driving in the low to mid rmp range in 1-3 gears My engine sputters. Its fine above that but my pipe is uncorked and gets pretty loud for res. streets. I bought I with all of the free mods done but I do not know how the fuel screw is adjusted or how it is jetted. What will I need to do to fix my problem. I also have some popping when I slow down. Thanks

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ncmountainman

Posted March 27, 2005 - 03:13 PM

#2

alot of people have that complaint with the JD kit. ask the feller you bought it from. or if you take it apart and the needle is red or blue it's JD's. he's in the jetting forum,and will help you dial it in. :naughty: if its popping on decel turn your a/f screw out a 1/2 turn. turn it all the way in (clockwise) first counting the turns in as your not to exceed 3 turns out. if its that far out already than you need to go up one on the pilot jet.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.