My Yz426 -00 won't rev.....


12 replies to this topic
  • Apjon

Posted March 15, 2005 - 01:47 AM

#1

Hello!

I have a problem with my yz426 -00. It will start up OK and idling is no problem either. It's when I try to give it some gas it just won't rev... I have changed the sparkplug and removed the carburetor and cleaned it, checked for airleaks but I can't find any problem... Please Help!

  • buck_y_lee

Posted March 15, 2005 - 02:25 AM

#2

Checked your fuel filter?

  • Apjon

Posted March 15, 2005 - 06:51 AM

#3

Yupp.... And fuel is flowing freely from the gastank....

  • mkporn

Posted March 15, 2005 - 06:55 AM

#4

What does it do? Does it fall on its face and die? Keep running but loads up? Spit and sputter.... Did it do it before you cleaned the carb or after? Did it get worse and worse or did it just stop reving?

  • John_Lorenz

Posted March 15, 2005 - 11:53 AM

#5

Hello!

I have a problem with my yz426 -00. It will start up OK and idling is no problem either. It's when I try to give it some gas it just won't rev... I have changed the sparkplug and removed the carburetor and cleaned it, checked for airleaks but I can't find any problem... Please Help!


make sure you did not put the slide plate in backward on the carb

Also
If the Bike will not rev, go and check all the wiring make sure that all is plugged into the correct connects. The CDI controls High alow speed as well. If it is burbeling when trying to rev then this could be an issue

  • Apjon

Posted March 15, 2005 - 12:27 PM

#6

Well... I drove it a week ago and it worked just fine, then I cleaned it off, started it and warmed it for a while, then week later it's just bad.. It won't die, but it won't rev either... Idling is normal.... :)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • jamieyz426f01

Posted March 15, 2005 - 12:30 PM

#7

your air filter aint bunged up is it?

  • John_Lorenz

Posted March 15, 2005 - 01:03 PM

#8

Well... I drove it a week ago and it worked just fine, then I cleaned it off, started it and warmed it for a while, then week later it's just bad.. It won't die, but it won't rev either... Idling is normal.... :)


If that is the case then I suspect you may have blown a connection off the CDI or got it wet and its corroded.

I will sy go over the wiring make sure each connect is clean. Pull each connect off wire brush it and place a dab of grease to keep it from corroding.

I seal my wires after doing this with silicon as well.

On last thing remove the Kill Switch from the Handle bar or unplug it (Temporary) See if it revs with the kil switch unplugged

  • Apjon

Posted March 15, 2005 - 11:35 PM

#9

My airfilter is new, I will go over all electrical connections next.. Thanks for all suggestions...

  • STEPN1HALF

Posted March 23, 2005 - 07:33 AM

#10

Hello, you probably have a "potato in your tailpipe" ie if you have a spark arrestor screen in your silencer its plugged with carbon crud, remove the insert and test ride

  • bevo0611

Posted March 23, 2005 - 06:22 PM

#11

I just posted a thread and sounds like you have the same problem my buddy has. Dealer told him it was the CDI box and the throttle positioning sesor. So save yourself $300.00 and check those out

  • WRookie

Posted March 23, 2005 - 07:57 PM

#12

Another easy check is the diaphragm in the accelerator pump. It might be torn.

  • Apjon

Posted March 24, 2005 - 12:07 AM

#13

Nope we don't use spark arrestors in Sweden and the exhaust (FMF) is clean, but when I removed the light blue wire it came alive again... When I tested the neutral switch with a tester it seemed ok but obviously it has to be a some shortcircuiting in it when I ride the bike....





Related Content

Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • * * * * *
  • 1 review
  • Last review by Tommyk_55
  • On January 15, 2017
Forums
Photo

05 yz450f not fast enough by RedeyeYZ


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  38 replies
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo

Should I buy this bike? help....... by Numsa Hul


Dirt Bike   General Dirt Bike Forums   What bike should I buy?
  • * * * * *
  • 10 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.