HELP with Devol Rad Guards


3 replies to this topic
  • jackofall

Posted March 09, 2005 - 07:52 PM

#1

I just received the Devol Radiator Guards I bought for my 04 WR450. They weren't bad to install, but now I don't have a way to reattach my shrouds. One of the bolts in the shroud attached to the louver. With these guards, the louvers aren't used. Anyone experience this and have some hints??

  • Gadsen

Posted March 09, 2005 - 08:05 PM

#2

There is a bracket that has 2 screws that hooks into the Devol guards, the scoops now hook that those. I installed Devols on my 04 WR450 and had no trouble. Are you missing some parts ot the kit? Was the package opened?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • jackofall

Posted March 09, 2005 - 08:42 PM

#3

Thanks Tech. My kids opened the package before I got home. They said they didn't take anything out. When I asked 'em where they opened it I went and looked and lo and behold right there under the couch was exactly what you described that I needed. Appreciate the help, I love this forum. :) :) :p

  • Gadsen

Posted March 09, 2005 - 09:50 PM

#4

Thanks Tech. My kids opened the package before I got home. They said they didn't take anything out. When I asked 'em where they opened it I went and looked and lo and behold right there under the couch was exactly what you described that I needed. Appreciate the help, I love this forum. :) :) :p



Cool, go easy on the kids, this dirt bike stuff gets them super excited too. Glad you found the missing parts! :D




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.