Anybody else have Edelbrock probs?


2 replies to this topic
  • CapXR650R

Posted March 01, 2005 - 05:03 PM

#1

I bought an Edelbrock QS carb for my XR650R. I can't get it to run. I removed the OEM carb from the bike, and the bike was running perfectly. I installed the QS, and the bike is almost impossible to start, and when I can get it running, it will run only for a minute or so before it quits.

If I so much as let the clutch out in neutral, it will kill the engine. If I try to blip the throttle it will die. If I don't hold the throttle just off idle, it will die. If I just let it run at a fast idle, it will run for a minute or so, and then it dies.

I have had the carb on and off a few times. Dismantled and reassembled under the direction of Edelbrock tech support. No difference. Edelbrock has agreed to take it back and re-work it. But this sucks.

So, I wonder if anyone else has similar problems with their QS?

Cap

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Old_Man_Time

Posted March 01, 2005 - 05:21 PM

#2

I had a lot of problems with the fuel shut off valve sticking in mine. I seemed to have resolved that problem and really like the Edelbrock over the stock although my stock carb performed pretty well but not near as nice as the Edelbrock once you get the problem resolved. I have noticed that if I don't turn the idle way up it doesn't start well and will not keep running until the motor is really warmed up. As it warms up I keep turning the idle down until I get the sweetest idle you could ever ask for.

I polished my shut off needle to a smooth shiney finish and it has never stuck since. I don't know but could it be you simply are not getting enough fuel? If there is a defect in the carb they will back their product until it works right. By the way those of us who have had problems with the carb are in the minority. So that should be comforting to you. Generaly this product is great. :)

  • BWB63

Posted March 01, 2005 - 05:34 PM

#3

I had one of my Edelbrock float valve get stuck while pre-running the Baja. It was on my son's bike and it got stuck just sitting. We hit it with the wood handle of a hammer and it let loose and worked the rest of the week. Like I have said before, the one on my bike had major problems right at the Edelbrock shop when we were running the bike on the dyno to find the difference between caburetors. Haven't had any problems sense with that carburetor once we got it fixed. I hope to not have any problems with the second one any more but, if I do I'll get to the bottom of the problem and find a fix





Related Content

Forums
Photo

ignitech programmable XR650L CDI by brianhare


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  60 replies
Forums
Photo

2015 XR650L Squeaking noise by Crayjay


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies
Forums
Photo

DirttyPig 2005 Xr650l Prroject! by braapmebb1moretime


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 22 replies
Forums
Photo

93 xr650l Restoration Project by Zigster


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies
Forums
Photo
Supercross

Supercross Preview 2017 Part 1: Championship Contenders by Chris Cooksey


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  181 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.