95 XR600 Decompressor Mishap???

1 reply to this topic
  • johno74

Posted February 27, 2005 - 05:31 AM


'95 XR6

Took the head cover off to inspect cam and chain etc due to what i judge to be excess noise.

Looking at the decomp mechanism on the cam it all seemed quite loose...? It did only seem to rotate one way tho.

Put the head cover back on and started up, the decomp pickup(where the cable attaches on the engine) was being moved up and down about 1cm and makes a nasty tapping noise. Does anyone know what ive done wrong?

I took the cover off again to check everything and now the cover doesnt want to sit down square FU£*£ (*%&*(%!!!

Any guidance much appreciated!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • bootlegger2

Posted February 28, 2005 - 03:42 AM


have you got the motor on top dead center so the rockers arent on the lobes of the cam

Related Content


Cle Elum Sunday 5/29: Looking for dual sport tips by TigerTanker

Dirt Bike   Dirt Bike Regional Discussion   Northwest
  • Hot  32 replies

2015 XR650L Squeaking noise by Crayjay

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies

1993 XR600R rebuild by ove

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  41 replies

Which thumper motor for a street tracker? by woz

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • * * * * -
  • Hot  29 replies

Engine Loping/Sputtering by tcaldwell

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 2 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.