Eratic Idle - Brand New 2005 WR450F

41 replies to this topic
  • BNutZ

Posted May 02, 2005 - 06:48 AM


*** RESOLVED ***

My Eratic Idle issue is no more... after riding the bike twice, once locally and another time in Hollister it is no more. Not sure if I buy the whole "spur of aluminum in the pilot jet" diagnosis... Nonetheless, while riding in Hollister two weeks ago, the Eratic Idle simply stopped.. I rode again this past weekend - and no eratic idle! :naughty:

Just finished jetting, didn't get the results I was looking for.... more on this in a later post....

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JeffWR

Posted May 02, 2005 - 07:59 AM


On the 250WR & 450WR 05's I have noticed on the carburetor boot closest to the cylinder that it leaks on the very bottom because the clamp has a stop in the middle. It happens when you get 40miles on your 250WR and 60 miles on the 450WR. Look for dirt on the carburetor boot, and if so that may be your problem. I have the 2005 450WR and I took out the stop and tightened it up and haven't had any leak problems since.

Do you mean the cylindrical washers (1/2" long) that slide over the screw? If so, I wholeheartedly agree, toss 'em. I don't see why they would make them too long. The only danger may be pinching the boot somehow.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.