03 charging system


2 replies to this topic
  • scheffaa

Posted February 25, 2005 - 04:01 AM

#1

i bought my 03 wr450f brand new from the dealer mid year 2004. when i got it the battery was dead because it had sat in a showroom for nearly two years. i replaced the batter with the corect one but the bikes charging system seems to be having trouble charging it. it is a breeze to kik start but seems a waste to have an electric start and only be able to use it sometimes.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • mjslim

Posted February 25, 2005 - 12:55 PM

#2

I've never had a problem with mine, but for starters I would check to see that your charging system is putting out the proper voltage when the bike is idling. Assuming it should work similar to a car's system (you electrical weenies may want to jump in here), I would think the voltage across the battery leads should be in the 13.5-14.5 volt range when the bike is idling. Start the bike up, put a volt meter on the leads and see what you get. Also check to see what the manual has to say about checking the charging system.

  • ETP

Posted February 25, 2005 - 04:40 PM

#3

Ditto what mjslim says.
Also, the WR450 charging system is not a real powerful. It seems have enough juice to keep a well charged battery charged while riding, but not enough to recharge a weak battery while riding.
At the advice of some fellow TTr's, I just bought a Battery Tender Jr. which charges my battery in the garage the night before riding. $29 at Pep Boys. :)




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.