Rear brake Drag???? Help!


4 replies to this topic
  • WR4BLUE6

Posted February 17, 2005 - 11:11 PM

#1

I need a little help. I have an 02 WR426 and I love it. It's set up for off road, hare scrambles and the like. It's loaded: Clarke tank/ YZ seat, Scotts triple clamp with stabilizer, Rekluse auto clutch, BR 1 suspension, Ti-4 with powerbomb, MAXXIS Cross IT front and rear, the works baby. :)

Anyway enough bragging. The problem is this - I think I'm experiencing a bit of rear brake drag. The rear tire just isn't free spinning like it used to. And I noticed that when I spin it backwards it makes a vibration. I put my hand on the caliper and the vibration is coming from the caliper.

So how do I fix it? :) I looked at the manual which goes over the rear brake, but I do not see how I would aleviate any pressure. The brake lever does not appear to be depressed.

Everything is straight as far as the rear axle, rim, etc. And there was a time not too long ago when the rear tire would spin freely forever.

I don't know what happened??? :p

HELP a BLUE BROTHER out :D

  • gregwr450f

Posted February 17, 2005 - 11:41 PM

#2

You might have a bit of crap or rust in the caliper piston, bleed the brake right through with fresh fluid after that try to push the piston back and forth with your fingers while the brake line is undone, is it feels free put more fresh fluid through making sure to bleed all the air out and then go over you mates house and tear up his front lawn :)

Ps Are you sure it is not a stuffed bearing

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Chris_from_Oz

Posted February 18, 2005 - 12:11 AM

#3

Like Greg says, check for stuffed wheel bearings, and make sure the caliper piston/s move freely, no binding. Also could be unevenly worn brake pads or disc, chain condition and adjustment (worth a look, even though you are certain the vibration is in the caliper). You've already isolated the area, just check everything in the vicinity, you'll find it. :)

  • Indy_WR450

Posted February 18, 2005 - 04:33 AM

#4

Just put on a new rear pin and pads. Usually that takes care of the issue. If not then you need to replace the piston and seal in the rear caliper but I doubt that it is seized. :)

  • Frostbite

Posted February 18, 2005 - 06:26 AM

#5

Take your rear pads out and check the ends that fit in the caliper slot, opposite end from the pin. I was dragging my rear a bit and found that the tab, (end without the hole) on one pad had bent and it was keeping the caliper from floating properly and centering on the disc. I put new pads in and the wheel spun free like the front.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.