Buddys yz426f, popps and shoots flames

12 replies to this topic
  • Crf450ex

Posted February 14, 2005 - 01:55 PM


Well, my friend has a yz426, it used to pop last year, but just this weekend he tried to start it, and the float was stuck up so it was not getting any gas. We fixed that problem, but now when it is reved it shoots flames. My thought is that it might be lean because of the cold which would cause it to pop, but would that cause flames? My second thought is that the valves are not propperly adjusted. There could be no clearence, would that cause flames and viloent back firing?

Well any input would be great. Thanks a lot.

  • 642MX

Posted February 14, 2005 - 02:03 PM


Have you adjusted the fuel screw?

  • grayracer513

Posted February 14, 2005 - 02:11 PM


Please clarify: are you saying that it pops and backfires on acceleration, or deceleration?

  • Crf450ex

Posted February 14, 2005 - 02:48 PM


When you rev it in nuetral up to 1/4 throttle and past it popps on the return to idle. It runs weak on the acceleration in gear, and pops on the deceleration. I have considered moving the needle clip to the next richer possition. But the jetting is all stock, and so is the rest of the bike. I do not see how it could pop so violently if it is just a little lean from the temps. Because that is the only variable that has changed.

We returned the pilot screw to stock 1.25 turns out. It ran crappy, then we turned it out a whole half of a turn more and it still ran bad.

  • grayracer513

Posted February 14, 2005 - 02:59 PM


Decel backfire is almost always caused by one of two things. It may be a little lean at idle, in which case the backing out the fuel screw should fix it. Or, very often, it happens because there's an air leak in the exhaust, usually a loose fit or clamp at the midpipe/header joint, or at the head.

The jet needle won't exhaust decel backfiring, and the backfiring is generally not related to problems with poor acceleration.

  • Crf450ex

Posted February 14, 2005 - 05:26 PM


Is valves a possiblity? Because we cleaned the carb pretty well. The exhaust is clamped tight. The carb is secure. Oh and another thing, it seems to run with less popping when the choke is on, meaning it is lean right? But what i dont understand if it is all stock, and it is assembled correctly why would it be popping with stock jetting?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • jimmyg

Posted February 14, 2005 - 06:07 PM


when you took apart the carb did you take the slide out ? if you di its real easy to put the back side of the slide on upside down.i have seen a lot of people do this and end up with the same condition.the plate thats on the engine side of the carbcan be put in upsidedown. look through the carb with the slide 1/2 way up. the bottom of both sides of the slide should have the same profile like a half mooni if it doesnt you need to take the slide out & turn the plate 180 degrees.

  • rlharber

Posted February 14, 2005 - 06:21 PM


My 1999 yz400 did that after changing the factory silencer to the FMF PC4. FMF recommended that I Jet it to their specs.

Jetting Information
Main Jet: 178-180
Pilot Jet: 45
Needle: STOCK
Needle Position: 4TH

It solved a lot of the excessive back firing issues, I also added the Ty Davis airscrew and can adjust this if it backfires at higher altitude. It seems to start a lot easier too. another cause backfires can result from the jets having build up or even small particles in them.


I hope this helps.

  • Crf450ex

Posted February 15, 2005 - 03:06 PM


i am definatly going to check the slide, and the jets more thoroughly. THanks a lot for th help

  • yzf450jack

Posted February 15, 2005 - 04:26 PM


Sure sounds like the black plate on the slide is upside down :)

  • Crf450ex

Posted February 15, 2005 - 04:42 PM


It very well could be, i didnt do the carb my friend did. I dont know if he pulled that out but its possible. I will also check that.

  • "ReNeGaDe ReYnOLDs"

Posted February 15, 2005 - 05:22 PM


hahaha, thats similar to a guys quad if seen before. When he backs up, it pops and crackles, and then shoots out a little flame for every pop! i have no idea what to tell you, sorry man

  • MichiganMXer

Posted February 16, 2005 - 06:24 AM



Try this first, its the easiest.

Related Content


yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F

Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.