Electrical problems

2 replies to this topic
  • Supermoto XR600r

Posted February 11, 2005 - 01:42 PM


I've just been having a nightmare with my XR600, first of all the bike just stopped working in the middle of nowhere, got the thing home and found that there was no spark coming from the plug done the normal changed the plug still nothing then changed the ignition coil and still nothing then got talking to the guy in the garage and he told me that the slator coil is the thing that normally goes on the RX6 so got a new slator coil and great the bike started :cry: , but when you revved the engine it just didn't sound right and the back light was not working :cry: , so left it for a while and got back working on it again.
Disconnected all the lights and fired it up again and it sounded fine even when you revved the engine, so started connecting the lights system 1 by 1 and got to the very end and the bike still sound fine but the back light is still not working, the head light working fine but it’s a bit dim until you rev the engine, but I am still not getting any power going to the back tail light and the horn is not working either, there is no indicators on the bike and no key to turn it on, just kick it and it starts, I’ve chase the wires that are coming from the tail light to under the saddle and there still no power coming from where the back light connects to the lume, if any has had the same experience could you please HELP

Thanks everyone who has read this far and helped.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Supermoto XR600r

Posted February 14, 2005 - 05:08 AM



  • TooShort4XR

Posted February 14, 2005 - 02:37 PM


Just replied to your first post and could perhaps be of help as I have had an XR for the last 10 years (it seemed like a good idea at the time and now I just won't give up) as I had mentioned in the post about the stator, I would think your problem is with the REG/Rectifier (Located near the Headlight) as your headlight runs off the other Reg, and at a guess I would think that it is the Capacitor as there are 2 solder joints that could crack, have a look and get back to me.
Post a question half way around the world and get a reply from a Corkman, Go Figure!!!. :)

Related Content


2015 XR650L Squeaking noise by Crayjay

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 3 replies

Which thumper motor for a street tracker? by woz

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • * * * * -
  • Hot  29 replies

1993 XR600R rebuild by ove

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  41 replies

What was your path to Beta? by officialhopsof

Dirt Bike   Make / Model Specific   Beta
  • Hot  79 replies

XR650L super moto wheels by greggkklee

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  28 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.