backfire HELP


7 replies to this topic
  • dirtguy

Posted January 28, 2005 - 08:39 PM

#1

I just finished all the mods on my 2005 WR450. pulled the grey wire, put in the JD needle jet (blue) and #170 main jet for my altitude and installed the Zip-Ty mixture screw at 1-3/4 turns out, pulled out the exhaust baffle. Cut down the throttle stop to 20mm on the shaft. Left the AIS installed because without it the bike wont idle and sounds & smells real rich.

but now when i blip the trottle i get a single pop or backfire. What causes this??

i want to go out and test ride tomarrow so PLEASE respond tonight thanks

  • jasilva

Posted January 28, 2005 - 09:04 PM

#2

Pull the AIS off. Plug the openings in the cylinder and airbox when you remove it. You'll need to get Lowedogs AIS block off kit or some vacuum plugs for the airbox and pulse line(intake side of the cylinder) and a 1/8" pipe plug and the correct tap for the exhaust manifold fitting. Also if you didn't remove the airbox snorkel you need to. With the snorkel in place your intake is still restricted.

Joe

  • jbrooks26

Posted January 28, 2005 - 09:07 PM

#3

I'm not expert, but I believe that sounds like a rich mixture problem. Unburned fuel enters the exhaust and is ignited. I think this is helped by disabling the AIS. If it smells and runs rich, then lean out the jetting. Just my 2c. Hope it helps.

Josh

  • dirtguy

Posted January 28, 2005 - 09:08 PM

#4

oh yeah i forgot to list that i removed the snorkel also

the AIS can't be causing the backfire--it did not backfire before the other mods- any suggestions

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • jasilva

Posted January 28, 2005 - 09:13 PM

#5

The AIS is causing the backfire. The AIS injects fresh air into the exhaust providing oxygen for any unburned fuel(which exists in any properly jetted engine's exhaust stream). You don't backfire stock because the stock jetting is way lean which is bad for your engine's longevity.

Joe

  • dirtguy

Posted January 28, 2005 - 09:19 PM

#6

thanks for clearing that up---off it comes

  • simica

Posted January 28, 2005 - 09:51 PM

#7

I don't understand why some people are having this problem and some aren't. Here is my setup. Try it if you haven't already torn off the AIS.

All of the free mods plus:
1. Leave the AIS on.
2. Keep the stock needle in.
3. One size up on starter, pilot and main jets.
4. Storm fuel screw at 1 and 3/4 turns out.
5. Install Power Now

The power now is probably not needed to help with the backfire problem, but with all of the above together, my bike is a rocket with no hesitation or backfiring when blipping the throttle and pulls hard through all the gears and can easily keep up with my friends KTM 525.

Just another way to consider. BTW, the AIS is how this bike became green sticker for us in California just like the smog system in your car allows it to be registered and is illegal to remove. Don't be surprised if some day an observant Ca. park ranger cites an '05 WR for removal of the AIS.

  • jasilva

Posted January 28, 2005 - 10:10 PM

#8

Try uncorking the exhaust, this will make the backfire noticable(trust me its doing it now you just don't hear it) and put an 04 needle in set the the 3rd clip position. If you think its fast now you'll be suprised how much more is available.

Joe




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.