Starter problems?


21 replies to this topic
  • Indy_WR450

Posted January 02, 2005 - 11:23 AM

#21

Just look up Marcusmoberg posts and make sure you are not drinking pop while you are reading all of his posts. I always get some up the nose reading his posts! :cry: :cry: :cry: :cry:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gloft

Posted January 03, 2005 - 12:39 PM

#22

:cry: My 03 Starter motor started squeeking the last ride I did, when I pulled it I checked it WAS the motor and Not the starter clutch !
Having ascertained it WAS the motor I stripped it and found lots of water/grit in the brush/commutator end of things.....a quick clean, a dab of grease and a quick re-assemble later it is fine.it turns better and has stopped making noises !

one quick word of warning tho if you do strip the starter motor, mark ALL three parts end/centre/end for alignment as if you rotate them out of line...the motor runs backwards...... :cry:


Sounds like my problem. Before I dissambled the starter I checked with the local dealership. A new starter is over $300.00 (ouch!). You've given me hope that a cleaning is all that's needed (seems we ride nothing but mud around here these days). Thanks for the heads up on the allignment :cry: I'll post an update when I know more.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.