Engine popping


4 replies to this topic
  • socalduner

Posted November 08, 2004 - 12:14 PM

#1

My 426 has started popping and if you crack the throttle off idle it rev's very high, and wont stop until I hit the kill switch. The filter is clean and the jetting unchanged. Any Ideas? :cry:

  • Riel250f

Posted November 08, 2004 - 12:48 PM

#2

Check the carb boots, could have an air leak.
My boot ripped (on the cylinder side) when I landed off a jump too hard.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • yzf450jack

Posted November 08, 2004 - 08:21 PM

#3

You might have an exhaust leak

  • socalduner

Posted November 09, 2004 - 06:48 PM

#4

I think it was the carb boot. I was reading the instructions for the power now, and it said if the boot wasn't in the groove right the idle would be high and erratic.Thanks for your help. :cry:

  • John_Lorenz

Posted November 10, 2004 - 06:50 AM

#5

My 426 has started popping and if you crack the throttle off idle it rev's very high, and wont stop until I hit the kill switch. The filter is clean and the jetting unchanged. Any Ideas? :cry:


When was the last time you took the carb apart and cleaned it thoroughly?

If the idle is hanging as you said above, then a few things can be an issue
1: Cable can be frayed, causing the hanging
2: Dirty Carb/Clogged Pilot/Fuel Airway
3: Air leak in rubber manifold (Between Carb and Head)
4: Throttle tube is damaged and hanging

I would say its time to do a very close once over on your whole assembly Throttle tube to Carb :cry:





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.