Xr650L dead

5 replies to this topic
  • mountainrider

Posted October 24, 2004 - 02:57 PM


It quit raining and I decided to take a spend got about a mile down the road and it quit running.No fire to the plug.Got the service manual out along with the ohm meter and have yet to find a problem.I have a 250L so I tried the coil and CDI unit from it and nothing.It must have a bad connection somewhere. :confused:I just hope it does not take to long to find it.

  • NukBoy

Posted October 25, 2004 - 09:54 AM


This may sound stupid but I had a similar problem and I would have to hit the battery box while driving to get it running again. The battery connection will rattle itself loose even though it may look tight. Take off the wires, scrub them with a wire brush, the put them back on. It worked for me.

  • MXbob60

Posted October 25, 2004 - 02:21 PM


Early 650L's had problems with the kill switch failing, I'd check there first.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • DesertWill

Posted October 25, 2004 - 06:40 PM


I bumped the kill switch to the off position on mine when I was getting gas. Took me a couple of minutes to figure out what was going on. Hope it's something simple.

  • mountainrider

Posted October 26, 2004 - 02:40 AM


It is the CDI module.Even though the one off of the 250 plugs right in they are made different.Someone said to tap on it and sometimes they will start firing again,I did and it worked.I do not see how tapping on an electronic module would make it work again. :cry: But there are a lot of things I do not know.Thanks for the help.

  • NukBoy

Posted October 26, 2004 - 08:17 AM


Animul Mutha is one of the Quirkiest bikes I have ever owned. Sometimes tapping on things, bending things, and just simple guess work makes the bike run better. She is for sure the best project bike I have ever owned. She will keep you on your Mechanic Toes. Thank goodness she is so easy to work on.

I got 9000 miles on mine before uncorking it. Once you start changing it from stock its amazing how much you have to keep changing stuff.

I thought it was the module as well and took everything out of the battery box and cleaned it up and put it back together again. But it kept going dead, so I would hit the battery box untill the power came back on. Then the light started flickering. So at night I would be driving down the road and my headlight would start to go out. And then come back on. Here I am doing 70mph down the freeway at night doing a "Ride em Cowboy" hitting the battery box with my left hand to get the lights back on. The problem was getting worse and quickly. So I took the battery off and started check one wire at a time. I finally realized that the bottom nut inside the battery connection was corroded and needed to be scrubbed. Once I got it cleaned and tightened everything back down it has had no power issues since.

Related Content


What was your path to Beta? by officialhopsof

Dirt Bike   Make / Model Specific   Beta
  • Hot  79 replies

Would a Young Scott Summers still be Competitive today on an XR600R? What would he ride to be competitive today? by Jayzonk

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  141 replies

1993 XR600R rebuild by ove

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  41 replies

93 xr650l Restoration Project by Zigster

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies

Can anyone identify this xr600 piston? by ms_mtn24

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 4 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.