Mud in carb


9 replies to this topic
  • stink

Posted October 12, 2004 - 08:13 PM

#1

I have an 04 wr 450 and I went to install a JD jet kit and when I pulled the bottom off there was a large amount of mud right near the hole for the drain. Yesterday we went riding in wet and muddy conditions. The bike stalled a couple of times in wet mud. I had a real hard time getting it started and keeping it running. I pulled the filters out of the gas tank and they are totally clean. How can mud get into the carb? My air filter was fine also. Cheers S.

  • 5valve

Posted October 12, 2004 - 10:47 PM

#2

i think through accelerator pump
clean the whole carb including acc. membrane and put a lot of grease in the rubber seal on top of the pump

  • stink

Posted October 13, 2004 - 09:24 AM

#3

I did clean the carb thoroughly, I will have a look at the pump. Thanks for your help. Cheers S.

  • stink

Posted October 13, 2004 - 01:14 PM

#4

Where ius the accelerator pump located on the carb? Bottom right corner? Cheers Sean
P.s the yami manual sucks ass! :cry:

  • 5valve

Posted October 14, 2004 - 07:03 AM

#5

bottom right with rod pressing in from top...pull the throttle and check for movement in that area ; )
crap can enter via rod

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ncmountainman

Posted October 14, 2004 - 07:26 AM

#6

it may have come in the vent hoses,reroute the two that cross over the top of the carb. make them go past the battery into the airbox,and just let them dangle down in there. why yamaha left lines that suck air down in the dirt would be a good debate question! :cry:

  • stink

Posted October 15, 2004 - 09:58 AM

#7

Are the two hoses the ones with the black plastic clip holding them together? Directly over the front top part of the carb? Thanks S.

  • ncmountainman

Posted October 15, 2004 - 03:18 PM

#8

ya they are 1/8"or 3/16" ? clear pinkish colored lines i think there are only two that go over the carb. :cry:

  • stink

Posted October 15, 2004 - 03:59 PM

#9

Thank you very much for your help. Cheers S. :cry:

  • Racing227

Posted October 15, 2004 - 06:55 PM

#10

Watch for the Hot Start cable too. I notice water in the hot start hole in the carb. :cry:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.