3 replies to this topic
  • Yellowdog

Posted April 24, 2002 - 01:54 PM


I've got a '96 XR 628 with a Keihin carb on her. It will start cold, but as it gets hot, and runs for a while, you have to kick it about 10 minutes to get it to turn over. New plug, clean jets... What else can it be? It's almost as if it floods itself while running. Could the drainage tube be clogged? Any ideas out there?

  • qadsan

Posted April 24, 2002 - 03:24 PM


If this bike worked OK for 'you' when 'you' rode it last and now it's having this problem at the same riding temperatures and altitudes it previsouly worked fine at for 'you', then the problem is most likely with the spark plug (you've already changed it), the jetting or some kind of electrical problem. Check all your wiring very closely.

If this is a new bike to you, or if you're riding this bike at significantly different altitudes or temperatures than you last rode it when everything worked OK, then the problem is likely in the jetting.

If a bike starts okay cold, but then is hard to start when it's hot (as youv'e said), then the pilot jet is likely too rich. This would be the first thing I'd change if I had this problem with my bike.

If your bike ever starts fine hot, but coughs when cold, the pilot jet is too lean and you can test this out by partially engaging the choke while your running. If it runs better at a lower throttle opening with the choke on, then it's a dead giveaway that the pilot jet is too lean.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Moredesert

Posted April 24, 2002 - 07:10 PM


Sounds good qadsan, You can try putting the choke on half way when its hot and if it starts better your too lean. I had that problem so I raised the needle one notch.

One thing I didn't hear mentioned was the valves. If there too tight you will have hot starting problems. Been there done that too.

  • XR6's_rule

Posted April 24, 2002 - 09:51 PM


YELLOWDOG- I have experienced a similar problem with an XR6 before. Check your stator (exciter coil). This coil supplies the spark and when the bike is started cold it would be fine, but the stator could be bad, causing intermittent spark problems when the coils are hot (warm engine). Check the resistance of your stator with a multimeter. Switch it to ohms x100 and measure the resistance of the exciter coil by putting one end in the red/white connector and one to ground, the measurement should be between 230 and 320 ohms, if it's a long way out of that range, replace or rewind the stator. Failing that, clean your carb and try different pilot jets.

Related Content


ignitech programmable XR650L CDI by brianhare

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  57 replies

Post Apocalypse, ThumperTalk style! by Justin Pearson

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  35 replies

Which thumper motor for a street tracker? by woz

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • * * * * -
  • Hot  29 replies

Cle Elum Sunday 5/29: Looking for dual sport tips by TigerTanker

Dirt Bike   Dirt Bike Regional Discussion   Northwest
  • Hot  32 replies

What was your path to Beta? by officialhopsof

Dirt Bike   Make / Model Specific   Beta
  • Hot  79 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.