Joe Racer VS Baja Designs The winner is


28 replies to this topic
  • qadsan

Posted September 27, 2004 - 08:55 PM

#21

I dont feel it clicking at all and i do feel it going into the slot that feels right has anyone else ran into this prob ?



Make sure you're holding the throttle wide open, then gently push down on the tool and turn it until you feel it slide onto the slot. Once it's in there, you should feel it click, but the throttle has to be held wide open.

  • 3920

Posted September 28, 2004 - 06:08 AM

#22

Yes i did hold it open all the way when pushing the adjusting tool all the way down and turned clockwise 1/2 turn. Still didnt feel any clicking bike ran better after warming up and riding a few miles when letting off idle was much higher and would idle down in about 10 to 20 seconds checked all cables all looked good so whats up with that ? did get rid of backfire tho thank god. should i turn back 1/4 turn for final adjustment on idle ?

  • qadsan

Posted September 28, 2004 - 06:40 AM

#23

Something's not right. The bike should idle down much quicker than 10 to 20 seconds. Make sure you don't have an air leak between the carb & intake. You did cut out and or replace the stock intake manifold for the non EPA version, yes? Make sure those clamps are tight. I have mine setup so there's just a hint of popping on deceleration at times.

  • 3920

Posted September 28, 2004 - 07:13 AM

#24

Yes i did uncork everything and did the blockoff kit as well I have checked and tightned the clamps front and back of manifold and collector bolts seems like a vaccum leak but where i dont know checked all caps on blockoff everything looks fine to me any ideas ? P.S. yes i did replace the manifold with factory hrc manifold

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • qadsan

Posted September 28, 2004 - 07:28 AM

#25

Did you trip the alignment tab off the new rubber intake so it fits perfectly flush against the carb? That alignment tab is there for the stock carb, but gets in the way for the Edelbrock as I recall. Maybe that alignment tab doesn't interfere with the newer Edelbrocks, but it used to with the older ones and fitment wasn't perfect until that tab was trimmed off. That might be something to check.

  • 3920

Posted September 28, 2004 - 07:31 AM

#26

Okay Im on it ! all i recall the carb went on smooth as silk but it's comin off again tonight ........thanks :cry:

  • Ibis

Posted September 28, 2004 - 08:07 AM

#27

qadsan, did you set up your z Start Perch Adjuster with the light spring?

  • qadsan

Posted September 28, 2004 - 08:44 AM

#28

yes

  • Old_Man_Time

Posted September 28, 2004 - 09:18 AM

#29

qadsan, did you set up your z Start Perch Adjuster with the light spring?


I use the lighter spring also but I did try the stiffer spring at first and did not like the engagement. For trail use the lighter spring is the way to go.





Related Content

Reviews

Honda XR650L 2016 by Chris.GVS


Honda XR650L 2016
  • - - - - -
  • 0 reviews
Forums
Photo

Fell Off Trailer by usafxr


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  43 replies
Forums
Photo

ignitech programmable XR650L CDI by brianhare


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  60 replies
Forums
Photo

93 xr650l Restoration Project by Zigster


Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies
Forums
Photo
Supercross

Supercross Preview 2017 Part 1: Championship Contenders by Chris Cooksey


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  141 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.