JamesNow users- heads up


4 replies to this topic
  • cowboyona426

Posted August 21, 2004 - 08:36 PM

#1

My bike has been cutting out at 3/4-full throttle openings lately, and I wanted to eliminate the simple stuff like dirty carb and air filter before starting on electrical stuff. So I pulled my carb tonight to clean it, only to find that the plate in my JamesNow (the first one made by James himself) had somehow gotten bent and pulled up toward the top of the carb bore :thumbsup: I'm just glad it didn't get sucked into the motor, and thought I'd give everyone else a heads up to keep an eye on theirs.

  • Satch0922

Posted August 22, 2004 - 03:19 AM

#2

interesting. Maybe the metal you used is not thick enough or did not fit into the intake bell tight enough?? :thumbsup:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • cowboyona426

Posted August 22, 2004 - 01:38 PM

#3

The metal appeared to be thick enough, but it may not have been wide enough for the bell, who knows. I just can't figure out what caused it to bend like it was... I never noticed much of a difference anyways, so running without it probably won't hurt a thing.

  • Satch0922

Posted August 22, 2004 - 05:32 PM

#4

Maybe a backfire?

  • cowboyona426

Posted August 22, 2004 - 06:27 PM

#5

Hmm... possible, but not likely I don't think. I never noticed it backfiring before it started running poorly. Maybe it's just the massive power of the monster 426 motor... :thumbsup:





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.