yz 400 motor knock


6 replies to this topic
  • hontrx265r

Posted August 15, 2004 - 02:43 PM

#1

Just seeing if any of you have some ideas. I have a 99yz400 that I installed a 426 rod, cylinder bigbored to 96.5 (439cc)and a weiseco piston that I believe is 13:5:1 I started it and their is a horrible knock coming from what I believe to be the top end (possibly valves?) hitting the piston or something along that route any suggestions the head gaskets have also been doubled up. could the skirt be hitting something

  • DoctorRzed

Posted August 15, 2004 - 02:57 PM

#2

I would check the valves, but I would think you need to run race gas in that beast.

  • hontrx265r

Posted August 15, 2004 - 02:58 PM

#3

I'm running klotz 114 octane race gas

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • DoctorRzed

Posted August 15, 2004 - 03:00 PM

#4

Whats the diff between the 426 rod and the 400?

  • Rich_Rohrich

Posted August 15, 2004 - 03:10 PM

#5

Whats the diff between the 426 rod and the 400?


The wrist pin size was increased by 1mm, otherwise it's the same.

You might want to start by verifying the cam timing is correct. If possible do it with a degree wheel to ensure that neither of the cam gears has moved from their original position on the cam.

Checking piston to valve clearance during assembly is also pretty important when you bump up the compression.

  • sirthumpalot

Posted August 16, 2004 - 12:48 AM

#6

To check the piston/valve clearance, remove the head and put a very small amount of puddy on the piston where the valves are most likely to hit it. Assemble the motor and with the spark plug out SLOWLY spin it over. Remove the head and by looking at the puddy you can see if the piston and valves made contact.

That said, you've got a pre-01 engine. Before you check anything else, have you checked the key shaft on the counter balancer? A fairly common problem on the older bikes is that key will get worn and the gear gets loose on the shaft and from what I understand it can make quite a racket.

  • yz426onNOS

Posted August 16, 2004 - 01:20 PM

#7

I'm running klotz 114 octane race gas


:thumbsup: :lol: A fellow Klotz user! :devil: :awww:

If it were your valves and the timing was off by one tooth. The valves would hit and bend, in most cases. Try race gas bro. Check the keyway, timing, and did you check all the measurements? You also need special head gaskets when running high comp. Motors as well as high octane gas.





Related Content

Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.