My front brakes wont work?


5 replies to this topic
  • DoctorRzed

Posted August 14, 2004 - 11:15 AM

#1

I was at the track and lost it around a corner. It fell on the right side. Not a hard crash at all. I went to squeeze my front brakes and there was no pressure and the didnt work. There is no fluid leaking anywhere? If I got Air in the brake line whould it cause the loss of pressure?

  • Jeffro426

Posted August 14, 2004 - 11:44 AM

#2

Check your calipers and make sure nothings binding, and try bleeding the brakes...no pressure in the breaks either means you got a nasty leak your not seeing, or a massive amount of air somewhere in there.

  • DoctorRzed

Posted August 14, 2004 - 12:22 PM

#3

Ill have to go get some brake fluid. IfI do havea leak Ill get the lightspeed cr kit :thumbsup:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • motocross15_3

Posted August 14, 2004 - 04:04 PM

#4

bleed the brakes or they can be ceised up this happened to my old bike

  • yzf450jack

Posted August 14, 2004 - 06:11 PM

#5

Try holding the lever in with tape for an hour or so it should come back add brake fluid if its low :thumbsup:

  • Fastest1

Posted August 14, 2004 - 06:50 PM

#6

Reset your forks, they are probably tweaked.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.