Just installed Magura Hydro clutch, bangs into gear

2 replies to this topic
  • YZ426FPilot

Posted July 21, 2004 - 08:31 PM


I just installed a Magura Jack on my 02 YZ426. I installed the spacer & checked the freeplay clearence, but when shifting from N to 1st, it shifts much firmer into gear than before. Its also very difficult to push or start in gear with the clutch pulled in. Basically the clutch is not disengaging all the way. Is this normal for the Magura system? :thumbsup:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • YZ426FPilot

Posted July 22, 2004 - 01:41 PM


Anybody? I know people out there have them on their 426s...

  • yzf450jack

Posted July 23, 2004 - 06:32 PM


Try turning the little red adjuster in it will give more pull :thumbsup:

Related Content


YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F

Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies

Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Snake pit oct 30th by The Anvil

Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  106 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.