AC Pump?

7 replies to this topic
  • MGR_8

Posted July 29, 2002 - 07:51 AM


Tried to go riding yesterday...didn't happen. I couldn't get the beast to fire. Thought I fouled a plug....totally dry plug. Made sure I was getting a spark...getting fire. Twisted the thottle more times than suggested...still have a dry plug.

Pull the jets out, clean them, take apart ac pump, dirty but not that bad, clean it. Twist throttle many times(5-10 times, should be REALLY fouled), still dry plug. Curse a lot and go home.

Try to start it this morning, first kick fires off....runs fine. Let it sit a couple minutes, won't start back up. Dry plug again. Pull carb out, but keep the fuel line connected...not squirting anything, turn fuel off and drain gas out of carb, I get a little squirt. Now no squirt. Any ideas...the diaphram looks fine.

Bike ran fine the last time out...two weeks ago. I am not sure where to start. Any suggestions would be appreciated.

It's an 01 426 with bk! Wish my new 450 was here!


  • SaNdSliNGer

Posted July 29, 2002 - 07:58 AM


Is your fuel cap vent hose clogged this happened to me once and when I found out what it was I was so relived remember always check everything even if you think it could not affect it

  • Shawn_Mc

Posted July 29, 2002 - 08:54 AM


Ya check the vent hose and the float valve. Try turning on the gas with the bowl plug out. Make sure youve got flow. Aint no go wit out no flow.
Also make sure the passage from the accel. pump to bowl isnt plugged. But do the flow check first, its easiest and probably the culprit.

  • MGR_8

Posted July 29, 2002 - 09:15 PM



Tried that...
Question...the ac pump really doesn't keep the bike running..its the vacuum?..right?

Doesn't make sense that it(ac pump) won't pump. Doe's anyone know what a bad diaphram looks like...what am I looking for? It has to be the pump because it ran first thing this morning.

I am pretty much stumped! Thanks for the suggestions so far..keep them coming.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • DaveJ

Posted July 29, 2002 - 10:41 AM



Your dry plug doesn't really mean anything other than a symptom.

You are either not getting a spark, or not getting fuel.

First, make sure you have fuel in the carb by opening the carb drain valve.

If this checks out, then check for a good healthy blue spark.

Let us know what you find.


  • DaveJ

Posted July 29, 2002 - 10:42 AM


Whoops, you might be getting a spark but at the wrong time.

Sometimes when CDIs fail they will work when cold, then get goofy when hot, (either by use or by outside temps). I doubt this is your problem, but I just wanted to mention it.


  • moto2000

Posted July 29, 2002 - 02:34 PM


When you cleaned the carb, did you pull the plastic cover off the side of the carb by the throttle cables? The ac pump picks up off of the throttle pulley and goes through a plastic pivot (where the timing screw and BK mod are located). That pivot can got jammed up with grit and not allow the pump to work correctly. May just need some contact cleaner or WD -40 to flush it out.

  • Shawn_Mc

Posted July 29, 2002 - 02:49 PM


The vaccum from the engine pulls fuel through the passages in the carb. The AC pump only squirts momentarily then the engine pulls the fuel past the needle, pilot and main jets (not in that order). There are air passages that atomize the fuel that can also plug up, and cause poor running, a false rich condition. or possibly a lean condition depending on the throttle opening. So, take the carb off, and work the throttle and make sure your getting fuel out of the AC pump. Dont look down the intake port side of the carb, and work the throttle. If you do and it works, your going to get squrited in the face! The carb has a relatively simple job, most of the time if it works,it works right, unless its got dirt in it somewhere. Use compressed air to clean everything out. Make sure the AC pump has fuel to the diaphram. There is also a check valve in the diaphram that prevents the fuel from backing back into the bowl. Make sure its sealing. If it has dirt in it, the diaphram will simply pump the fuel back into the bowl, instead of getting a squirt.

Related Content

WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

Is it worth it? (Cam and High compression piston) by macgi77

Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.