Dead XRL

12 replies to this topic
  • Beemerbum

Posted May 29, 2004 - 03:18 PM


My 93 XR650L is giving me fits. It starts,runs5-15 seconds, then dies.Cleaned float bowl,main jet, no different. Have gas to floatbowl(runs out open drain).Doesn`t seem to make difference choke on,off.Oh yeah,after it dies it won`t restart for 2-3 minutes, then dies again. Any suggestions?TIA

  • minioutlaw

Posted May 29, 2004 - 03:39 PM


Is your gas cap venting? Maybe the vent hose is clogged.

  • Beemerbum

Posted May 29, 2004 - 03:57 PM


Tried that,no different. I just went out to the garage,it started ran about5 minutes,I shut it off. Tried to start it again,same as before-died after 5 seconds

  • Dual_Dog

Posted May 29, 2004 - 06:02 PM


My 93 XR650L is giving me fits. It starts,runs5-15 seconds, then dies.Cleaned float bowl,main jet, no different. Have gas to floatbowl(runs out open drain).Doesn`t seem to make difference choke on,off.Oh yeah,after it dies it won`t restart for 2-3 minutes, then dies again. Any suggestions?TIA

At the risk of sounding too general, how's the ignition system? Does the plug have a strong spark and is the plug wire good. Could be faulty ICM, Ignition Control Module, bad coil or ignition pulse generator. (By the way this is all straight out of the Honda Service Manual)

How about the float valve, is it sticking? Maybe improper choke operation, carb out of adjustment, intake pipe leaking, bad gas...

How about the compression? Everything normal there?

Hope this gives you a few more ideas of how to solve your problems. Best of luck. You may also want to post this over at the XRL usergroup on Yahoo also. Those guys are an excellent resource for the BFP.

  • heliosstudios

Posted May 29, 2004 - 09:04 PM


Process of elimination. 3 things are needed to make an engine work... compression, ignition, fuel. When it won't start, pull the plug boot, stick a new plug in it, ground it to the case, and crank over the engine. Got strong spark? If so, that's not the problem. Run a compression test. Ok? Then it's gotta be something fuel-related. Remove the entire fuel system and service from the ground up. Don't rule out bad gas or slime in the tank! Create a checklist and don't leave anything out... you'll find the problem.

  • JetPilot

Posted May 30, 2004 - 02:43 AM


The previous post could not have been more wrong. Just because you have a spark when it starts doesnt mean that the ignition is ok. Its possible that you could have a bad ignition module that quits working as soon as there is a real load on it and the internal components start to heat (5-15 seconds) Start it, and when it quits, check right away to see if you have a spark or not. I would also check for carburation problems, thats also a very good possiblity.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • heliosstudios

Posted May 30, 2004 - 04:29 AM


... PRECISELY why you test for spark when it is NOT working... which is exactly what I said! How is that wrong?

  • JetPilot

Posted May 30, 2004 - 12:27 PM


Misread your post. You were right on, check it when it wont start ! Be quick about it, if it cools and works again before you check it, you could miss finding where the problem is.

  • heliosstudios

Posted May 30, 2004 - 04:45 PM


Any word on how it's coming? I must say, the spark test is quite general and may be inconclusive. The ignition module may be messed up in a way in which it still fires, just at the wrong time. I'd check all the fuel stuff first and if everything is pristine and within service-manual specs there, then borrow a friend's CDI and coil, install them, and plug them in. (The bolts are part of the electrical circuit too.) Wouldn't hurt! :thumbsup:

Keep a log of everything you try and if you don't find the problem, post the checklist here and someone is bound to help figure it out.

  • Beemerbum

Posted May 31, 2004 - 03:34 PM


With the plug out,I get spark for 2-3seconds then no spark.Tried with known good plug,same thing.Whadda ya think-CDI, coil,something else? I don`t have another CDI or coil to swap in.I`m no electrical whiz,But resistance in coil is 0. Also coil to end of plug wire is way below spec. TIA,Jim

  • heliosstudios

Posted June 01, 2004 - 03:48 AM


Hmm, if it sparks at all, it sounds like the coil is working... it could be an intermittent coil but I'd imagine that would be kinda rare? Anyone have a coil go bad? It's probably the ignition module. Some things to check would be to make sure all the module's wires are unplugged, cleaned, and reconnected securely. Unbolt it, make sure it has good electrical contact on the bolts. Make sure the pickup coil's connection is good. It might be just a loose or poor connection somewhere. Of course take out the fuses and check those too. Look for any corroded or rusty connections anywhere and clean 'em up. If all else fails, you could order replacement parts in order of cost... the spark coil, pickup coil, and ignition module (perhaps not in that order.) A place to get OEM parts online is .

Does anything else electrical misbehave, like do the lights dim excessively or cut out when the bike dies? If so that might be indicative of some other problem like the regulator or battery shorting out. You're close now... :thumbsup: don't give up. :awww:

  • MotoChris521

Posted June 01, 2004 - 09:52 AM


This may sound silly but try another plug.My old 94 did the same thing .I was preping it for sale and i put in a "better" looking used plug than the one that was in it.I also rejetted the carb for the stock pipe.So i go to start it and it ran for 30 sec. and dies.It took me a while to figure it out.I put in a new plug and it ran great. So......maybe ? :thumbsup:

  • Beemerbum

Posted June 01, 2004 - 11:32 AM


I think I found it. A friend suggested replacing the resistor plug cap- So far it`s working fine. File this for future reference- He said his stuck him 20 miles from home and drove him crazy too.Thanks guys

Related Content


93 xr650l Restoration Project by Zigster

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • 17 replies

Post Apocalypse, ThumperTalk style! by Justin Pearson

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  35 replies

Fell Off Trailer by usafxr

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  43 replies

XR650L super moto wheels by greggkklee

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  28 replies

1993 XR600R rebuild by ove

Dirt Bike   Make / Model Specific   Honda   XR600/650
  • Hot  40 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.