White Bros. E2?


5 replies to this topic
  • 6t8amxetc

Posted May 27, 2004 - 01:51 PM

#1

Has anybody installed one on their bike yet? Or even heard or seen one up close? I am thinking of getting one for my WR426 but would like to get some feedback first. Thanks...Ty

  • yamaharichey

Posted May 28, 2004 - 06:59 AM

#2

I was wondering the same thing, but I guess not.

  • dez4ever

Posted May 28, 2004 - 09:26 AM

#3

I bought one to put on my 450 specifically for the purpose of it being 96db...didn't happen. Brand new out of the box she blew almost a 99db!!! I called White Bros about this and they said that they were aware of the problem and that they were in the process of trying to fix it. They said the the sound meter they used during R & D was different than the one the Forestry service uses and that is where the difference came from. They also said they would warranty the pipe once the fix has been figured out. As for the performance??...As usual with most "Quiet" pipes the power seems to be robbed from the bottom end the most. I ran it with both the quiet core and wide open and wasn't really impressed either way. If it were 96db like it was advertised it guess it would have worked better than the other quiet pipes if used.

With that all said...I've got one barely used White Bros E2 pipe for sale if anyone is interested.

Bob

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Guest_Guest_*

Posted May 28, 2004 - 11:44 AM

#4

I heard the same from a 450 owner. I just installed a pc496 and it failed at 97.5 :thumbsup: The stock silencer with a insert (pmb) passed at 94, but lost a little on top. :awww:

  • 6t8amxetc

Posted May 28, 2004 - 01:49 PM

#5

I may be interested. Although I'm not sure if it would fit my bike. 01 WR426. I seem to recall someone recently posting that they had installed a 450 muffler on a 426. Haven't found the post yet. PM me what you would like to get out of it. What muffler are you going to use now?

  • PowerFiend

Posted May 28, 2004 - 06:33 PM

#6

I ordered one for my 426 through the TT store 3 weeks ago, then it went on backorder the day it was supposed to ship. It is now 2 days past the revised ship date and still haven't heard anything. I don't know that the E2 is ever going to ship, it has been promised to us for over 6 months.

I should have gone with the Dr.D. :thumbsup:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.